Forum needs upgrade for 7.2 of PHP - questionable.